Нужен код на с++! : напишите программу, которая удваивает все буквы "z" в строке (нужно, чтоб строка изначально вводилась с клавиатуры) пример: было (zozo) стало (zzozzo)

asura3 asura3    3   03.10.2019 01:20    4

Ответы
lex9090 lex9090  09.10.2020 12:54

Держи -_-

#include <iostream>

#include <string>

using namespace std;

int main()

{

   string a;

   cin>>a;

   for(unsigned j=0;j<a.length();j++){

       if (a[j]=='z')  a.insert(++j,"z");

       

   }

   cout<<a;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика