tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Найдите количество элементов
Найдите количество элементов массива, которые отличны от наибольшего элемента не более чем на 10%.
BonYseT
1 30.08.2019 03:30
43
Ответы
ahmadieva05
06.10.2020 04:17
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
var max:=a.Max;
Writeln('k=',a.Where(x->x>=0.9*max).Count)
end.
Пример
n= 20
9 1 -9 -8 -4 3 -5 -8 10 7 -9 1 -5 -4 0 -4 9 6 9 -8
k=4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sonicbum
12.06.2019 00:30
Сколько символов текста можно передать за 5 секунд,используя модем, работающий со скоростью 1200 бит\с; 14400 бит\с?...
odyvanchik22
12.06.2019 00:30
Разработать алгоритм и составить программу на выбранном языке программирования ( паскаль или qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12...
nizametdinovaalina
16.11.2019 08:17
Придумайте свой алфавит. напишите с него сообщение размером v=20 бит...
Ipgt
16.11.2019 08:18
Что бы я не делал у меня получается 36, но в ответе написано 30. , ...
blecstar2000
16.11.2019 08:18
Тут мало ! составить формулу в excel...
Dhffhjh
16.11.2019 08:24
Можно без объяснений, а краткий ответ.разбирая склад древней техники, катя обнаружила непонятный прибор с клавиатурой и дисплеем. при включении прибора на дисплее появилось предложение...
ananasik79
16.11.2019 07:06
Свойством алгоритма является: 1)результативность; 2)цикличность; 3)возможность изменения последовательности выполнения команд4)возможность выполнения алгоритма в обратном порядке...
kseniamurzakova
27.08.2019 21:50
Составить программу которая позволяет ввести 50 целых чисел...
Нюся5012
15.12.2020 08:14
Какая формула находится в ячейке В2? *=МИН(В3:В5)=СУММ(В3:В5)=МАКС(В3:В5)=СРЗНАЧ(В3:В5)...
Влад5624
15.12.2020 08:15
4. За счет чего видеокарта увеличивает скорость вывода графической информации на экран? 1обрабатывает данные в своей оперативной памяти 2её процессор работает параллельно с главным...
Популярные вопросы
Отметь прилагательное во множественном числе : свежее, вкусный , весеннее ,...
2
Напишите основные этапы восстания пугачева (3 этапа)...
1
Краствору объемом 153,5 мл с массовой долей гидроксида калия 16% и плотностью...
1
Сумма,в которой первое слагаемое записано произведением чисел 456 и 12 ,а второе...
2
Вычисли площадь и периметр прямоугольника,если одна его сторона равна 7,8м,а...
2
Если посмотреть сверху на куб и шар какие фигуры ты увидишь...
2
1-чем объяснить полноводность рек бассейна амура не весной, а в половине лета?...
1
5класс номер 1330 число 35% которого равны 56, и число , 56% которого равны...
3
Прочитайте абзац.допишите имя героя рассказа и название произведения. давно,...
1
Доску длиной 2 м распилили на части по 5 дм.сколько частей получилось? может...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
var max:=a.Max;
Writeln('k=',a.Where(x->x>=0.9*max).Count)
end.
Пример
n= 20
9 1 -9 -8 -4 3 -5 -8 10 7 -9 1 -5 -4 0 -4 9 6 9 -8
k=4