Разработать алгоритм и составить программу на выбранном языке программирования ( паскаль или qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

odyvanchik22 odyvanchik22    1   12.06.2019 00:30    1

Ответы
Aleks5953 Aleks5953  09.07.2020 19:20
Var
  m, n, p: integer;

begin
  Write('Введите свой номер в группе: ');
  Readln(n);
  n := n * 12;
  p := 1;
  repeat
    m := n mod 10;
    p := p * m;
    n := n div 10
  until n = 0;
  Writeln('Результат ', p)
end.

Тестовое решение:

Введите свой номер в группе: 13
Результат 30
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика