Напишите программу вычисления выражения в программе Паскаль АБС
y = x^4 - 3x^3 + 5x - 6

merifai merifai    3   11.11.2020 17:32    3

Ответы
ИрБи562 ИрБи562  11.12.2020 17:33

program expression;

var

 x, y: real;

begin

 read(x);

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;

 write(y);

end.

Объяснение:

program expression;  // Название программы

var

 x, y: real;  // Две переменные являются вещественными (требуется для power)

begin  // Начало программы

 read(x);  // Вводим число с клавиатуры

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;  // Само выражение

power(число, которое нужно возвести в степень | сама степень)

power(x, 4)

x - число

4 - степень

 write(y);  // Выводим ответ

end. // Начало программы

ПОКАЗАТЬ ОТВЕТЫ
whitehawk1508 whitehawk1508  11.12.2020 17:33

##

var x := ReadReal;

var y := -6 + x * (5 + x * (0 + x * (-3 + x))); // схема Горнера

Print(y)


Напишите программу вычисления выражения в программе Паскаль АБС y = x^4 - 3x^3 + 5x - 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика