Напишите программу вычисления выражения: s=1! +2! +3! ++n! 5-9 класс здесь n! - факториал числа n. n! =1*2**(n-1)*n. используйте функцию вычисления факториала.

MedinaIsk MedinaIsk    3   22.09.2019 21:20    4

Ответы
lenusja272 lenusja272  08.10.2020 10:36
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var f: integer->real:=x->range(1,x).Aggregate(Real(1),(a,b)->a*b);
var n:=ReadInteger('n=');
write(range(1,n).Select(x->f(x)).Sum)
end.
ПОКАЗАТЬ ОТВЕТЫ
kozlovadasa52 kozlovadasa52  08.10.2020 10:36
Var s,j,k:longint;
function f(n:byte):longint;
var f1:longint;
i:integer;
begin
if n<1 then f1:=1
else begin
f1:=1;
for i:=1 to n do
f1:=f1*i;
end;
f:=f1;
end;
begin
s:=0;
readln(k);
for j:=1 to k do
s:=s+f(j);
writeln(s);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика