Напишите программы для следующих , организуя экран пользователя по предложенному варианту. 1: написать программу вычисления площади поверхности параллелепипеда. s=2*(a*b+b*c+c*a) введите данные а=9,в=7.5,с=5 экран пользователя: вычислите s поверхности параллелепипеда. введите исходные данные: длина(см)? 9 ширина(см)? 7.5 высота(см)? 5 площадь поверхности: 30000 кв.см. 2: записать программу вычисления стоимости покупки, состоящей из нескольких тетрадей и карандашей. экран пользователя: вычисление стоимости покупки введите исходные данные: цена тетради( 2.75 количество тетрадей? 5 цена карандашей( 0.85 количество карандашей? 2 стоимость покупки: 15.45 руб.

МиссПана МиссПана    1   17.06.2019 19:00    4

Ответы
mariainbox303 mariainbox303  14.07.2020 17:22
Program p1;

var
  a, b, c, s: real;

begin
  Writeln('Вычислите S поверхности параллелепипеда.');
  Writeln('Введите исходные данные:');
  Write('Длина(см)? '); Readln(a);
  Write('Ширина(см)? '); Readln(b);
  Write('Высота(см)? '); Readln(c);
  s := 2 * (a * b + b * c + c * a);
  Writeln('Площадь поверхности: ', s, ' кв.см.')
end.

Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.

program p2;
var
  ct,ck,s:real;
  kt,kk:integer;
begin
  Writeln('Вычисление стоимости покупки');
  Writeln('Введите исходные данные:');
  Write('Цена тетради(руб.)? '); Readln(ct);
  Write('Количество тетрадей? '); Readln(kt);
  Write('Цена карандашей(руб.)? '); Readln(ck);
  Write('Количество карандашей? '); Readln(kk);
  s:=ct*kt+ck*kk;
  Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.

Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика