. Напишите программу, вычисления рекурсивной функции. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = 5 при n = 0,
F(n) = 3•F(n–4), если n положительное,
F(n) = F(n+3), если n отрицательное.
Вычислите чему равно значение функции F(43)?

artemterebenin artemterebenin    1   27.01.2022 03:31    9

Ответы
Сапсан936 Сапсан936  27.01.2022 06:00

# Python

def F(n):

   if not n: return 5 # n == 0

   return (3*F(n-4)) if n > 0 else F(n+3)

F(43) = 7971615

ПОКАЗАТЬ ОТВЕТЫ
RatmirOspanov123 RatmirOspanov123  27.01.2022 06:00

питон:

def f(n):

   if n > 0:

       return 3 * f(n - 4)

   elif n < 0:

       return f(n + 3)

   else:

       return 5

print(f(43))


. Напишите программу, вычисления рекурсивной функции. Алгоритм вычисления значения функции F(n), где
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика