Напишите программу в паскале: найти сумму членов арифметической прогрессии , если известны ее первый член,разность и число членов прогрессии.

irhev73fa irhev73fa    3   29.06.2019 09:50    1

Ответы
Minikotik2007 Minikotik2007  02.10.2020 15:03
Var a,b,c,k:real;
begin;
write('Введите первое число прогрессии:');
readln(a);
write('Введите разность прогрессии:');
readln(b);
write('Введите число членов прогрессии:');
readln(c);
k:=((2*a+b*(c-1))/2)*c;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Софалия Софалия  02.10.2020 15:03
Program SAP;
var
S, d: integer;
i, N: byte;
a: array[1..255] of integer;
begin

write('Введите первый член арифметической прогрессии: ');
readln(a[1]);
write('Введите разность арифметической прогрессии: ');
readln(d);
write('Введите количество членов арифметической прогрессии: ');
readln(N);

for i:= 2 to N do begin 
 a[i]:= a[1] + (i - 1) * d;
 S:= S + a[i]
end;

writeln('Сумма членов арифметической прогрессии: ', S);
end.
ПОКАЗАТЬ ОТВЕТЫ
anyakosilo33 anyakosilo33  17.10.2020 06:38

ответ: на фото

Объяснение:

к первому фото

d - катет прямоугольного треугольника

h - второй катет прямоугольного треугольника так же является высотой трапеции

к второму

x - н-ый член арифметической прогрессии


Составьте блок-схему. ! 1)найти сумму членов арифметической прогрессии, если известны ее первый чле
Составьте блок-схему. ! 1)найти сумму членов арифметической прогрессии, если известны ее первый чле
ПОКАЗАТЬ ОТВЕТЫ
yanaiweey yanaiweey  17.10.2020 06:38
program arsuma;
var a1,an,d,Sum:real;
n:integer;
begin
writeln ('vvedite pervyy chlen');
readln (a1);
writeln ('vvedite raznost (a ne znamenatel)))');
readln (d);
writeln ('vvedite kolichestvo chlenov');
readln (n);
{vychislenie n-nnogo chlena}
an:=a1+(n-1)*d;
{vychislenie summy}
Sum:=(a1+an)*n/2;
writeln ('summa =',Sum:3:3);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика