Напишите программу в паскале на нахождение суммы главных диагоналей для квадратной матрицы. ,

igor6677 igor6677    2   06.06.2019 10:00    1

Ответы
asovgira asovgira  01.10.2020 20:31
Program matrica;
Uses crt;
Var a:array [0..8 ,  0..8] of integer;
       sum1,sum2,i,j:integer;
begin
randomize;
sum1:=0;
sum2:=0
for i:=1 to 8 do
begin
Writeln;
for j:=1 to 8 do
begin
a[i,,j]:=random(10);
if i=j then sum1:=sum1+a[i,j];
if i+j=9 then sum2:=sum2+a[i,j];
Write(a[i,j], '    ');
end;
end;
writeln('Сумма чисел первой диагонали -',sum1,'  'Сумма чисел второй диагонали' ,sum2,');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика