Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.

arinashabalina1 arinashabalina1    1   06.10.2019 15:40    4

Ответы
ученик1443 ученик1443  09.10.2020 23:50

var amount, sum, multi, i: integer;

begin

   amount:= 0;

   sum:= 0;

   multi:= 1;

   for i:=1 to 51 do begin

       if i mod 12 = 0 then begin

           writeln(i);

           amount:= amount + 1;

           sum:= sum + i;

           multi:= multi * i;

       end;

   end;

   writeln(amount, ' ', sum, ' ', multi);

end.

amount = 0

sum = 0

multi = 1

for i in range(1, 51):

   if i % 12 == 0:

       print(i)

       amount += 1

       sum += i

       multi *= i

print(amount, ' ', sum, ' ', multi)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика