Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 4. количество чисел не превышает 1000. введенные числа не превышают 30 000. программа должна вывести одно число — максимальное число, кратное 4.

Sera4erka Sera4erka    2   20.07.2019 03:30    17

Ответы
Alexxxxxxxxxxxxxxxey Alexxxxxxxxxxxxxxxey  07.09.2020 16:58
Program zadacha;
var n, x, i, max: integer;
begin
max:=0;
Writeln ('Введите количество чисел');
Readln (n);
for i:=1 to n do begin
readln (x);
if (x mod 4=0) and (x>max) then max:=x;
end;
writeln (max)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика