Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

annaYanna1 annaYanna1    1   25.08.2019 07:40    1

Ответы
NikitaVaselenk NikitaVaselenk  05.10.2020 18:17
Var
i,max,min,res,maxi,mini:integer;
a: array [1..15] of integer;
begin
writeln('Введите числа');
for i:=1 to 15 do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to 15 do
begin
if max<a[i] then begin
max:=a[i];
maxi:=i;
end;
if min>a[i] then begin
min:=a[i];
mini:=i;
end;
end;
if maxi>mini then
res:=maxi-mini
else
res:=mini-maxi;
res:=res-2;
writeln('между максимум и минимум = ', res, ' элементов');
end.
Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужн
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика