Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.

курочка5 курочка5    1   22.01.2020 21:35    6

Ответы
anastaseyaaaa anastaseyaaaa  11.10.2020 02:34

Объяснение:

Var s,n:integer;

Begin

   write('Введите число: ');readln(n);

   s:=0;

   While n<>0 do

    Begin

     if n mod 10 mod 2 = 0 then s:=s+n mod 10;

     n:=n div 10;

    End;

   if s<>0 then writeln('Сумма четных цифр: ',s)

    else writeln('Нету четных цифр в числе');

   readln;

End.

Может быть неправильной.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика