Напишите программу в паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года. считайте, что год невисокосный (365 дней). учтите, что слово "дней" может иметь также формы "день" и "дня". пример: введите день и месяц: 25 12 осталось 7 дней до нового года. пример: введите день и месяц: 1 1 осталось 364 дня до нового года. пример: введите день и месяц: 31 2 неверная дата.

RL228 RL228    3   20.07.2019 10:10    20

Ответы
DARINASTAR98 DARINASTAR98  03.10.2020 08:43
//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика