tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу в pascal дано
Напишите программу в pascal дано трехзначное число х. если х-четное число, то вычислить сумму цифр этого числа. если х-нечетное, то вычислить число-перевертыш
artenyancz
2 25.09.2019 22:50
3
Ответы
sydykovadiana
08.10.2020 19:29
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.
Примеры
n= 531
135
n= 428
14
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
bayramovameyra
17.09.2019 07:10
По информатике. дано: разрешение экрана - 1920*1080 глубина цвета - 32бита вопрос: сколько занимают 5 изображений?...
Anny2007Bell
14.08.2019 12:00
Впрограмме необходимо запросить от пользователя его имя. какой тип данных необходимо определить для такой переменной?...
Лена467744
10.07.2019 06:10
Для прогрессии 2,4,8, записать программу определения произведения членов прогрессии от номера 3 до номера 9 с натуральными номерами. вывести искомое произведение и величину сомножителей....
ulllyyy2010
10.07.2019 06:10
Необходимо на завтра написать программу вычисление в найти площадь треугольника, две стороны которого равны a и b, а угол между этими сторонами y...
safiya250707
28.06.2020 16:42
В одномерном массиве размерностью 2*n отсортируйте первую половину массива по убыванию, а вторую половину – по возрастанию. Можно использовать любой метод сортировки. Массив заполнить...
svetlanaariann
27.06.2020 16:18
Тест на тему «Память компьютера» 1 Что такое память? 1 Устройство компьютера, используемое для записи, хранения и выдачи команд программы и данных 2 Устройство компьютера, используемое...
JennieBlackpink1996
28.06.2020 16:21
PASCAL.ABC Для целочисленной матрицы G размерности N х M, найти для каждой строки число элементов, равных заданному значению ( N ≤ 10, M ≤ 10 )....
andreygaevskiy
27.06.2020 17:45
Написать программу на с++ Голодная зима. Суточный рацион коровы составляет u кг сена, v кг силоса и wкг комбикорма. В хозяйстве, содержащем стадо из k голов, осталось s кг сена,...
51Qwerty15
27.06.2020 17:29
Вопросы к экзамену по ОИТ 1. Информация. Виды и свойства информации. 2. Информационные процессы. 3. Информационные технологии. Классификация информационных технологий 4. Структура...
Тома1111111рок
31.01.2021 18:30
Выбери животное, которое попадет в закрашенную область....
Популярные вопросы
Начало церковной реформы никона, принятие соборного уложения,начало царствования...
1
Укажите сложное предложение 1)мокрый снег все залепил: окна домов,крыши сараев,перила...
3
Напишите сочинение-рассуждение, раскрывая смысл высказывания поэта и писателя...
1
Счем реагирует раствор нитрата бария: 1) cuso4 2) zn(oh)2 3) kbr 4) fecl3 и почему?...
3
Доказать что при любом значении n выражение 2n^3+7n-3 кратно 3...
3
Краствору силиката калия массой 20,53 г и массовой долей 15% прилили избыток...
3
Подчеркни числа кратные пяти: 45 18 5 20 24 12 40 25 32 10 16 35 48 15 30 № 2...
3
Как в чеховских рассказах соотносятся понятия личность и среда , быт и бытие...
3
Марфалогиялық талдау бұрынғы заманда қазақстан жерінде алтын,күміс,қорғасын,мыс,қалайы...
2
Вычислите: в числители: cos в квадрате 22,5 градусов -sin в квадрате 22,5 в знаменатели:...
3
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.
Примеры
n= 531
135
n= 428
14