Напишите программу, в которой необходимо организовать ввод многомерного списка (можно использовать рандомное заполнение) и выполнение действий с ним согласно своему варианту.
Для реализации программы используйте функции.
ЗАДАНИЕ:
Введите многомерный список, состоящий из целых чисел, количество элементов
определяет пользователь. Запросите у пользователя ввести номера двух строк и поменяйте
эти строки местами.
Используйте функции для ввода и вывода многомерного списка и для замены строк.
Python

jonni0203 jonni0203    3   01.12.2021 09:54    2

Ответы
ffbhhb ffbhhb  11.01.2022 00:05

import random

n, m = map(int, input().split())

a = list()

for i in range(n):

   u = list()

   for j in range(m):

       u.append(random.randint(1,1000))

   a.append(u)

k, l = map(int, input().split())

print("before changing: ")

for i in range(n):

   print(*a[i], sep=" ")

for i in range(m):

   t = a[k-1][i]

   a[k-1][i] = a[l-1][i]

   a[l-1][i] = t

print("after changing: ")

for i in range(n):

   print(*a[i], sep=" ")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика