Напишите программу в дельфи которая переводит число из десятичной в факториальную систему счисления.

виталий124 виталий124    1   29.08.2019 04:41    3

Ответы
kkseniyakach kkseniyakach  06.10.2020 02:09
Консольное приложение:
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
 begin
 i:=i+1;
 str(k mod i,m);
 f:=m+f;
 k:= k div i;
 end;
writeln('f = ',f);
end.

Пример:
n = 100
f = 4020
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика