Напишите программу требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. входные данные вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. координаты - целые числа в интервале от 1 до 8. выходные данные требуется вывести слово yes, если ладья сможет побить фигуру за 1 ход и no - в противном случае.

xxxromsavxxx xxxromsavxxx    1   09.08.2019 00:10    19

Ответы
gogoja gogoja  04.10.2020 06:11
//Dev-C++ 5.11 (C)

#include <stdio.h>
int main(void)
 {int x,y,xl,yl;
 scanf("%d%d%d%d",&xl,&yl,&x,&y);
 if((xl==x)||(yl=y))
  printf("YES");
 else
  printf("NO");
 return 0;}

Пример ввода:
4 4 4 2
Пример вывода:
YES
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика