Напишите программу сортировки массива строк по убыванию длины (на c++).Заранее

olyailysha31 olyailysha31    2   25.06.2020 02:51    3

Ответы
almiradkzbd almiradkzbd  15.10.2020 14:50

#include <iostream>

#include <vector>

using namespace std;

bool comp(string s1, string s2){

   return s1.length() > s2.length();

}

signed main() {

   int n;

   cin >> n;

   vector<string> a(n);

   for(auto &i: a)

       cin >> i;

   sort(a.begin(),a.end(),comp);

   for(auto &i:a)

       cout << i << ' ';

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика