tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу поиска
Напишите программу поиска всех двузначных чисел, в которых есть цифра n или само число делится на n.
20H
2 28.05.2019 16:50
10
Ответы
Polina68911
26.06.2020 10:16
Uses crt;
var a,n:integer;
begin
write('n:'); readln(n);
if n>=10 then writeln('error')
else
for a:=10 to 99 do
if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
ramzesrvc
26.06.2020 10:16
Dim i As Integer
Dim msg As String
Dim n As Integer
n = CInt(InputBox("Введите n"))
For i = 10 To 99
If CStr(i).IndexOf(n) > -1 Or i Mod n = 0 Then
msg = msg & i & vbCrLf
End If
Next
MsgBox(msg)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
artikiv2006
02.12.2019 13:40
Решите 3-4 по информатике нужно...
Arina3307
02.12.2019 13:46
Напишите следующие высказывания в виде логичиских воражений 1.спутники марса являеться фобос и деймос . 2. угол являеться поямым только тогда ,когда он равен 90° 3. наверное...
sokolovvw1
02.12.2019 13:48
Які племена мешкали на територіі сучасної україни до утворення київської держави?...
Semechko228
24.09.2019 18:40
Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2 до 10, вводимое с клавиатуры), паскаль. в цикле while или repeat until...
andreyglukhov7
07.09.2019 12:20
Мини рассказ как появилась ручка нужно...
лариса219
07.09.2019 12:20
Решите при регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 12 символов и содержащий символы латинского алфавита (заглавные и строчные),...
Behheheh
03.06.2019 16:00
Составить блок-схему,возводящая в квадрат меньшее из чисел и умножающая на 2 большее....
skyblue1
03.06.2019 16:00
Даны четыре различных целых числа. найти сумму тех чисел, которые больше 5. написать программу в packalabc.net...
тетрадка535243
18.04.2020 19:24
Решить примеры 100 mod 5 14 mod 3 15 mod 3 23 div 4 42 div 13 9 div 4...
nnnnn777
18.04.2020 19:24
Отметьте устройство компьютера, предназначенное для обработки информации. Если передаваемая информация потеряна или искажена, то в информационном канале были .. Помехи или плохая...
Популярные вопросы
5. Мәтіннен жанама ақпараттарды анықтаңыз. Жанама ақпараттар...
1
СОЧИНЕНИЕ КЕМ Я ХОЧУ БЫТЬ? (ХУДОЖНИК 4 КЛАССА)план:1)ДУМАЛ ЛИ Я О ВЫБОРЕ ПРОФЕССИИ?2)КЕМ...
2
4. Найдите равные треугольники и докажите на равенство:...
1
Укажи номера предложений с союзной подчинительной связью. (1) Я увидел впереди...
2
по английскому языку,надо написать сочинение по тебе Saving the World 5 класс....
1
Ребят решите, можно 1 и 2 не решать...
3
мне нужно сдать до завтра, Химия тест...
2
Нужно сделать задание, под номером 2,а то д/з кучу просто задали....
2
Напишите алгоритм Мыльного пузыря 6 этапов...
1
- Задание 1. Определите, какие утверждения являются «верными». (56) 1. Основатель...
3
var a,n:integer;
begin
write('n:'); readln(n);
if n>=10 then writeln('error')
else
for a:=10 to 99 do
if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln(a);
end.
Dim msg As String
Dim n As Integer
n = CInt(InputBox("Введите n"))
For i = 10 To 99
If CStr(i).IndexOf(n) > -1 Or i Mod n = 0 Then
msg = msg & i & vbCrLf
End If
Next
MsgBox(msg)