Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2 до 10, вводимое с клавиатуры), паскаль. в цикле while или repeat until

Semechko228 Semechko228    2   24.09.2019 18:40    11

Ответы
yakovlevakristi yakovlevakristi  08.10.2020 16:18
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  if n.Between(2,10) then begin
    var i:=1;
    repeat
      Write(n,'x',i,'=',n*i,' ');
      i+=1
    until i>10;
    Writeln
    end
  else Writeln('Число должно быть от 2 до 10')
end.

Пример
n= 6
6x1=6 6x2=12 6x3=18 6x4=24 6x5=30 6x6=36 6x7=42 6x8=48 6x9=54 6x10=60
ПОКАЗАТЬ ОТВЕТЫ
OWERpass OWERpass  08.10.2020 16:18
Лови 
program znaniya;
var n,i:integer;
begin
write('Введите n ');
read(n);if (n<2) or (n>10) then 
begin
while (n<=1) or (n>10) do
 begin
writeln('Ошибка! Число n должно быть в диапазоне от 2 до 10');
write('Введите n ');read(n);
end;
end;
for i:=1 to 10 do writeln(n,'*',i,'=',n*i);
end. 
Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика