Напишите программу, подсчитывающую количество букв во введенной строке (слове).

lyubashabelyaeva lyubashabelyaeva    2   09.06.2019 05:40    4

Ответы
Hhhlff Hhhlff  01.10.2020 22:50
Var
  s: string;
  letters: set of 'А'..'я';
  i, n: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := 0;
  letters := ['А'..'я'];
  for i := 1 to length(s) do
    if s[i] in letters then n := n + 1;
  writeln('Количество букв в строке: ', n);
end.

Тестовое решение:

Введите текст
Это текст содержащий буквы, цифры (1,2,3,4), латиницу werwer sxFFSFw и зн"ачки [email protected]#$%#^
Количество букв в строке: 43
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика