Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна разрешать ввод одинаковых чисел.

пишитеответ пишитеответ    3   02.09.2019 09:40    4

Ответы
noellajyli noellajyli  06.10.2020 11:37
Вот листинг: 

"if freedom is outlawed, only outlaws will have freedom." © TSRh

Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна
ПОКАЗАТЬ ОТВЕТЫ
arlanout arlanout  06.10.2020 11:37
Const
   N = 5;
Var
   P:array[1..N] of integer;
   C,i,j,B:integer;
Begin
WriteLn('Введите пять целых чисел');
For i:=1 to N do
    Begin
    Repeat
    B:=0;
    Read(C);
    For j:= 1 to i-1 do
        if P[j] = C then B:=j;
    if B > 0 then WriteLn('Число ',P[B],' уже было'#13'Попробуйте ещё раз')
    else P[i]:=C;
    Until B = 0;
    End;
WriteLn('Полученная последовательность');
For i:= 1 to N do Write(P[i],' ')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика