Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.

plotnikdias plotnikdias    3   13.07.2019 03:30    3

Ответы
ФЛЭМЭНКО ФЛЭМЭНКО  03.10.2020 02:27
Var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
 begin
 if a[i]='1' then b:=b+st;
 st:=2*st;
 end;
writeln(b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика