Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++

uylia7 uylia7    1   19.03.2020 23:57    9

Ответы
sinikyn1001 sinikyn1001  12.10.2020 01:32

#include <iostream>

using namespace std;

int

main ()

{

 int n, i, t = 1, m, a[100]; \\ можно поставить свои ограничения;

 cin >> n;

 for (i = 0; i < n; i++)

   cin >> a[i];

 m = a[0] - 1;

 for (i = 0; i < n; i++)

   {

     if (a[i] > m)

{

  m = a[i];

  t = 0;

};

     if (a[i] == m)

t++;

   };

 cout << t;

 return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика