Напишите программу паскаль ! в последовательности целых чисел найдите минимальное число и количество его повторений

валентинка20 валентинка20    3   08.10.2019 10:30    4

Ответы
pandatka4ewa pandatka4ewa  10.10.2020 03:58

Var

 Ch, n, Min, kMin: integer;

Begin

 Write('Введите кол-во чисел последовательности: ');

 ReadLn(n);

 

 Min := 0;

 kMin := 0;

 

 WriteLn('Введите целые числа в кол-ве ', n, ' штук:');

 For n := 1 to n do

 Begin

   Read(Ch);

   if (Ch < Min) or (kMin = 0) then

   Begin

     Min := Ch;

     kMin := 1;

   End

   else if (Ch = Min) then

     kMin := kMin + 1;

 End;

 

 WriteLn('Минимальное число: ', Min);

 WriteLn('Кол-во минимальный чисел: ', kMin);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика