Напишите программу на языке си напишите программу, которая вводит два целых числа, a и b ( a < b ), и выводит через пробел 5 случайных целых чисел на отрезке [ a , b ] . входные данные входная строка содержит два целых числа a и b , разделённых пробелом. гарантируется, что a < b . выходные данные нужно вывести в одной строке через пробел 5 случайных целых чисел на отрезке [ a , b ] .

glebKoz glebKoz    2   02.08.2019 15:10    36

Ответы
Кисулятв Кисулятв  31.08.2020 07:58
#include <stdio.h>#include <time.h>
int main(void) {    int left, right, num = 5;     time_t t;

    scanf ("%d %d", &left, &right);

    if(left >= right)      {        fprintf(stderr, "min_num is greater or equal than max_num!\n");     }

    printf ("left = %d right = %d \n", left, right);    
    /* Intializes random number generator */    srand((unsigned) time(&t));
    /* Print num random numbers from left to right */     while (num > 0)     {       printf ( "%d ", left + (rand() % (right + 1 - left)) );        num--;     }
    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика