Напишите программу на языке Pascal, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Программа должна вывести одно число — максимальное число, кратное 4.
​

Губанова1234 Губанова1234    2   03.12.2020 18:16    7

Ответы
hrndo hrndo  02.01.2021 18:17

var

 number: integer;

begin

 var size := readinteger;

 var max := -32768;

 for var i := 1 to size do

 begin

   number := readinteger;

   if (number mod 4 = 0) and (number > max) then

     max := number;

 end;

 write(max);

end.

Объяснение:

var

 number: integer;  // Целочисленная переменная, хранящая вводимые с клавиатуры числа

begin  // Начало программы

 var size := readinteger;  // Считываем размер последовательности с клавиатуры

 var max := -32768;  // integer принадлежит диапазону [-32 768…32 767], взял за максимум самое маленькое число

 for var i := 1 to size do  // Идём от 1 до размера последовательности

 begin  // Начало цикла

   number := readinteger; // Считываем число последовательности с клавиатуры

   if (number mod 4 = 0) and (number > max) then  // Если число делится на 4 без остатка и оно > max

     max := number;  // max присваиваем number

 end;  // Конец цикла

 write(max);  // Выводим ответ

end. // Конец программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика