Написать программу в паскале. в заданном массиве найти количество чётных чисел. вывести исходный массив и результат.

аоп777777777777 аоп777777777777    3   01.07.2019 06:10    6

Ответы
Trusters2007 Trusters2007  24.07.2020 16:23
Вариант с вводом элементов:
Program prog;
uses crt;
var a: array [0..999] of integer;
    i, k, n: integer;
begin
clrscr;
write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
write('a[',i,'] = ');
readln (a[i]);
end;

for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k = ', k);
end.

Вариант с рандомными элементами:
Program prog;
uses crt;
var a: array [0..999] of integer;
    i, k, n: integer;
begin
clrscr;
randomize;

write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln('a[',i,'] = ',a[i]);
end;

for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k =' , k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика