Напишите программу на языке pascal.элементы массива а, удовлетворяющие условию а(i)> 5.5, переписать в массив в, а элементы, удовлетворяющие условию а(i)< =5.5, переписать в массив с. в массиве а m элементов.

СуПерБро123 СуПерБро123    1   15.06.2019 03:10    5

Ответы
Gufka965 Gufka965  12.07.2020 12:33
 var
  A,B,C: array[1..100] of integer;
  i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
 for i:=1 to n do
  begin
   A[i]:=random(10);
   writeln('A[',i,']=',A[i]);
   end;
for i:=1 to n do
   if A[i]>5.5
    then  
     begin
       j:=j+1;
       B[j]:=A[i];
      end;
 for i:=1 to n do
  if A[i]<=5.5
  then 
    begin
     K:=k+1;
     C[k]:=A[i];
    end;
for i:=1 to j do
 writeln('B[',i,']=', B[i]);
for i:=1 to k do
 writeln('C[',i,']=', C[i]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика