Язык паскаль, можно через while написать программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. используйте оператор repeat

taxirkuliev taxirkuliev    2   19.05.2019 16:03    8

Ответы
нэла1 нэла1  12.06.2020 20:58

Объяснение:

Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика