Напишите программу на языке c# дан файл f, компоненты которого являются целыми числами. никакая из компонент файла не равна нулю. числа в файле идут в следующем порядке: 10 положительных, 10 отрицательных, 10 положительных, 10 отрицательных и т.д. переписать компоненты f в файл g так, чтобы в файле g, числа шли в следующем порядке: а) 5 положительных, 5 отрицательных, 5 положительных, 5 отрицательных и т.д.; б) 20 положительных, 20 отрицательных, 20 положительных, 20 отрицательных и т.д.(предполагается, что число в компонент файле f делится на 40)

chip0523 chip0523    2   02.09.2019 13:30    7

Ответы
denisst105 denisst105  06.10.2020 12:19
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.IO;

namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            int[] A = File.ReadAllText("D:\\f.txt").Split().Select(x=>int.Parse(x)).ToArray();
//            for(int i = 0; i < A.Length; i++)
//               Console.Write("{0} ",A[i]);
            using (StreamWriter g = File.CreateText("D:\\g.txt"))
            {
                Console.WriteLine("\n{0}", "Введите номер задания (0 - а, 1 - б)");
                int C = int.Parse(Console.ReadLine());
                C = 5 + C * 5;
                int i = 0;
                while (i < A.Length)
                {
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ",A[j]);
                    i += C*2;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i -= C;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i += C*2;
                    for (int j = i; j < i + C; j++)
                        g.Write("{0} ", A[j]);
                    i += C;
                }
            }
            Console.ReadKey();
        }
    }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика