На ленте машины поста расположен массив из 2n ячеек. составить программу, по которой машина поста раздвинет на расстояние в одну ячейку две половины данного массива.

yasuper07p0ad9l yasuper07p0ad9l    1   16.07.2019 01:00    4

Ответы
DockVIP DockVIP  16.07.2019 01:00
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика