Напишите программу, на вход которой подаётся прямоугольная матрица в виде последовательности строк. После последней строки матрицы идёт строка, содержащая только строку "end" (без кавычек). Программа должна вывести результат транспонирования исходной матрицы. Элементы строк выводить через пробел.

Sample Input:
3 2
1 4
end

Sample Output:
3 1
2 4

Программу написать в Python.

123456sa 123456sa    1   20.03.2021 18:35    51

Ответы
умница06092006 умница06092006  20.03.2021 18:40

hi = 0

mas = []

while True:

   a = input()

   if a == 'end':

       break

   hi+=1

   mas.append([int(i) for i in a.split()])

for i in range(len(mas[0])):

   print(*[mas[g][i] for g in range(hi)])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика