Напишите программу на с++
известна зарплата каждого из 12 работников фирмы за каждый месяц первого квартала (3 месяца) определите
а. общую сумму выплаченую всем работникам
б. зарплату полученую каждым работником за квартал
в. общую зарплату всех работников за каждый месяц

TataSkate TataSkate    1   28.12.2019 07:28    37

Ответы
Lehanbratkov Lehanbratkov  03.09.2020 11:57

===== C++ 17 =====

#include <iostream>

using namespace std;

int main()

{

   srand(time(NULL));

   int n = 12, k = 3;

   int a[k][n];

   for(int i = 0; i < k; i++)

   {

       for(int j = 0; j < n; j++)

       {

           a[i][j] = (rand() % 35 + 25) * 1000;

           cout << a[i][j] << " ";

       }

       cout << endl;

   }

   cout << "\nОбщая сумма, выплаченная всем работникам: ";

   int s = 0;

   for(int i = 0; i < k; i++)

       for(int j = 0; j < n; j++)

           s += a[i][j];

   cout << s << "\nЗарплаты каждого работника за квартал:\n";

   s = 0;

   for(int j = 0; j < n; j++)

   {

       s = 0;

       for(int i = 0; i < k; i++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << "\nОбщие зарплаты всех работников по месяцам: ";

   for(int i = 0; i < k; i++)

   {

       s = 0;

       for(int j = 0; j < n; j++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << endl;

   return 0;

}


Напишите программу на с++ известна зарплата каждого из 12 работников фирмы за каждый месяц первого к
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика