Напишите программу на с# или на алгоритмическом языке, которая бы определяла количество пар чисел, подряд идущих элементов массива, в сумме не превышающих 217. массив должен содержать 50 неотрицательных чисел, не превышающих 1000. (нужно ).

анапияабдыганиева анапияабдыганиева    3   26.09.2019 07:40    1

Ответы
Kartrider Kartrider  08.10.2020 20:14
Using System;
namespace ConsoleApp1
{
    class Program
    {
        static void Main(string[] args)
        {
            Random r = new Random();
            int[] a = new int[50];
            int k = 0;
            for(int i = 0;i<50;i++)
            {
                a[i] = r.Next(1001);
                Console.WriteLine("a[" + i + "] =" + a[i]);
            }
            for (int i = 0; i < 49; i++)
            {
                if (a[i]+a[i+1] <= 217)
                {
                    k++;
                }
            }
                Console.WriteLine("Кол-во пар :" + k);
                Console.ReadKey();
        }
    }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика