Напишите программу на Python, которая ищет среди целых чисел, принадлежащих числовому отрезку [1024; 28921], числа, которые делятся на сумму всех своих цифр. Запишите в ответе сумму всех таких чисел. Например, в диапазоне [12; 20] есть следующие числа: 12,18,20. Поэтому
для этого диапазона ответом является 12+18+20=50.

asdfghjkl12347 asdfghjkl12347    1   18.07.2021 18:56    14

Ответы
killskorpion19 killskorpion19  18.07.2021 19:00

def delitel(n):

   summa=0

   while n:

       summa+=n%10

       n//=10

   return summa

summa=0

for i in range(1024,28922):

   if i%delitel(i)==0:

       summa+=i

print(summa)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика