Напишите программу на Паскале по обработке одномерных массивов. Количество элементов в массиве задается самим пользователем, а сам массив генерируется из случайных чисел. Результаты вывести на экран. Каждый элемент массива генерируется по следующей формуле:

x = random (B-A+1) +A

Вариант 4

В одномерном массиве, состоящем из n вещественных элементов, вычислить:

произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

kuchakshoevaZ kuchakshoevaZ    3   01.12.2021 16:57    4

Ответы
yanchikkostyas yanchikkostyas  12.01.2022 03:47

Программа:

Pascal:

№1)

const max = 100;

var

 arr: array[1..max] of real;

 i: integer;

 n, A, B: integer;

begin

 randomize;

 repeat

   write('n = ');

   readln(n);

 until n in [1..max];

 write('A = ');  readln(A);

 write('B = ');  readln(B);

 writeln('Массив: ');

 for i := 1 to n do begin

   arr[i] := random(B - A + 1) + A;

   write(arr[i]:5:1);

 end;

end.

№2)

const max = 100;

var

 arr: array[1..max] of real;

 A, B, s, pr: real;

 n, i, j, arrMax, arrMin: byte;

begin

 randomize;

 s := 0;

 arrMax := 1;

 arrMin := 1;

 

 repeat

   write('n = ');

   readln(n);

 until n in [1..max];

 write('A = ');  readln(A);

 write('B = ');  readln(B);

 writeln('Массив: ');

 for i := 1 to n do begin

   arr[i] := random(B - A + 1) + A;

   write(arr[i]:5:1);

 end;

 

 for i := 1 to n do begin

   if abs(arr[i]) < abs(arr[arrMin]) then arrMin := abs(i);

   if abs(arr[i]) > abs(arr[arrMax]) then arrMax := abs(i);

 end;

 if abs(arrMax - arrMin) = 1 then begin

   writeln(); writeln('Между минимальным и максимальным значениями нет элементов.')

 end

 else begin

   if arrMax < arrMin then begin

     j := arrMin;

     arrMin := arrMax;

     arrMax := j;

   end;

   pr := 1;

   for i := arrMin + 1 to arrMax - 1 do pr := pr * arr[i];

   writeln();  writeln('Произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами: ', pr:0:2);

 end;

   

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика