Напишите программу на паскале, которая 1)сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из .цифр единиц. по следующему примеру,: было число 15, т. к 1 меньше 5 то на вывод : число 55.. 2.2) если цифра десятков больше цифры единиц, то программа выведет двузначное число, состоящее из .цифр десятков. по следующему примеру,: было число 41, т. к 4 больше 1 то на вывод : число 44.. 3) на выходе программы нужно вывести число, на которое надо увеличить исходное . пример: ввели число 15. получили 55. на выходе программы получим: число 40 ( 55-15 =40)

jroslov jroslov    1   30.09.2019 18:02    4

Ответы
Keranius Keranius  09.10.2020 05:59
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите двухзначное натуральное число:');

 var (n1, n2) := (n div 10, n mod 10);

 var nn := n1 > n2 ? 10 * n1 + n1 : 10 * n2 + n2;

 nn.Println;

 (nn - n).Println

end.

Введите двухзначное натуральное число: 155540
ПОКАЗАТЬ ОТВЕТЫ
pampuzik pampuzik  09.10.2020 05:59

var a:integer;

begin

readln (a);

if a div 10 = a mod 10 then

begin

writeln (a);

writeln (0)

end else

if a div 10 > a mod 10 then

begin

writeln (a div 10,a div 10);

writeln ((a div 10 + a div 10*10)-a)

end else

begin

writeln (a mod 10,a mod 10);

writeln ((a mod 10 + a mod 10*10)-a);

end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика