Напишите программу на паскале а.выясните какие числа ввел пользователь: положительное или отрицательное? б.выясните какие числа ввел пользователь: четное или нечетное ?

dschunchewa2013 dschunchewa2013    3   30.07.2019 03:40    1

Ответы
пингвиниха20172018 пингвиниха20172018  03.10.2020 17:09
//Pascal ABC.NET v3.1 сборка 1219

Var
 n:integer;
begin
 readln(n);
 if n>0 then writeln('Положительное');
 if n<0 then writeln('Отрицательное');
 if n=0 then writeln('0');
 if n mod 2=0 then writeln('Чётное') else writeln('Нечётное');
end.

Пример ввода:
1
Пример вывода:
Положительное
Нечётное
ПОКАЗАТЬ ОТВЕТЫ
VikaPoluyan VikaPoluyan  03.10.2020 17:09
Var x:integer; 
begin 
writeln('Введите число'); 
readln(x); 
if x>0 then write('Число положительное и ') 
else write('Число отрицательное и '); 
if x mod 2=0 then write('четное.') 
else writeln('нечетное'); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика