Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, и выводится сумма цифр этого числа.
Язык программирования — Python

Dispensable Dispensable    3   04.11.2021 17:16    2

Ответы
dilfuza2105 dilfuza2105  04.11.2021 17:20

Программа:

Python:

Вариант 1)

N = int(input())

sum = 0

while N > 0:

   j = N % 10

   N //= 10

   sum += j

print(sum)

Вариант 2)

print(sum([int(j) for j in input()]))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика