Напишите программу на c++, ! программе на вход подаётся 10 вещественных чисел. выведите их в обратном порядке. пример ввода: 5.3 1.47 9.23 3.08 2.25 5.62 6.93 3.67 8.44 6.49 пример вывода: 6.49 8.44 3.67 6.93 5.62 2.25 3.08 9.23 1.47 5.3

ПоляКрасавица1 ПоляКрасавица1    2   05.05.2019 21:36    5

Ответы

#include <iostream>

int main()

{

float Number[10];

for (int i = 0; i < 10; i++) {

 std::cin >> Number[i];

}

for (int i = 0; i < 10; i++) {

 for (int j = 0; j < 10; j++) {

  if (Number[i] < Number[j]) {

   float temp = Number[j];

   Number[j] = Number[i];

   Number[i] = temp;

  }

 }

}

for (int i = 0; i < 10; i++) {

 std::cout << Number[i] << "\t" ;

}

return 0;

}

Объяснение:

Работает правильно, но возможно был допущен недочёт в алгоритме, для сортировки использовал пузырьковую сортировку.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика