Напишите программу, матрицу с рандомными числами. далее она должна определить наибольшее число в строке и вывести его напротив этой строки. также и со столбцами. язык- паскаль​

DaryaGoldman1812 DaryaGoldman1812    1   07.04.2019 23:11    2

Ответы
SuperChelovek SuperChelovek  28.05.2020 20:45

Var i, j,s,k, max:Integer;

A:array[1..10, 1..10] of Integer ;

Begin

Randomize ;

Max:=0;

For i:=1 to 3 do begin

Writeln;s:=0;

For j:=1 to 3 do begin

A[i,j]:=random(10) ;

Write(' ', A[i,j]);

If A[i, j]>s then

s:=A[i, j];end;

If s>max then max:=s;

Write(' ', s) ;End;writeln;

For j:=1 to 3 do begin

K:=0;

For i:=1 to 3 do begin

If A[i, j]>k then k:=A[i, j];end;

Write(' ', k) ;end;

Write(' ', max) ;

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика