Напишите программу,которая запрашивает у пользователя ввод чисел,пока не будет нажата цифра "ноль".на экран выводит сумму всех введенных чисел

romanowacristi romanowacristi    3   24.06.2019 03:30    3

Ответы
МозгиДемона МозгиДемона  19.07.2020 19:22
Program numSum;
var inp,sum:longint;
begin 
 repeat 
  readln(inp);
  sum:=sum+inp; 
 until inp=0; write('Sum - ',sum); readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
lizcarpova lizcarpova  19.07.2020 19:22
Var a,s:integer;
begin
writeln ('Введите целое число');
a:=1;
while a<>0 do
begin
readln (a);
s:=a+s;
end;
writeln ('Сумма всех введенных чисел = ', s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика