Напишите программу, которая запрашивает три цифры (от 1 до 9) и выводит число, получающееся из этих цифр в том же порядке, что и при вводе. Цифры подаются в одной строке через пробел. Sample Input:
1 2 3

Sample Output:
123

Dasssshenka Dasssshenka    2   20.11.2020 22:11    214

Ответы
6luille9 6luille9  20.12.2020 22:13

Java.

Объяснение:

import java.util.Scanner;

Scanner scanner = new Scanner(System.in);

int[] mas = new int[9];

for (int i = 0; i < mas.length; i++) {

   mas[i] = scanner.nextInt();

}

System.out.println(mas[i]);

ПОКАЗАТЬ ОТВЕТЫ
boda13 boda13  25.01.2024 12:20
Хорошо, давайте решим эту задачу вместе.

Сначала нам нужно запросить у пользователя три цифры (от 1 до 9). Мы можем использовать функцию input(), чтобы получить ввод от пользователя. Затем мы можем использовать метод split(), чтобы разделить ввод на отдельные цифры.

Давайте начнем с написания программы.

```python
# Запросить у пользователя три цифры
user_input = input("Введите три цифры (от 1 до 9) через пробел: ")

# Разделить ввод на отдельные цифры
digits = user_input.split()

# Вывести число, полученное из этих цифр в том же порядке
result = ''.join(digits)
print(result)
```

Теперь давайте разберемся, как работает наш код.

1. Запрашиваем у пользователя ввод трех цифр, используя функцию input().
2. Пользователь вводит три цифры, разделяя их пробелом. Например, "1 2 3".
3. Мы используем метод split(), чтобы разделить введенные цифры на отдельные элементы списка. В нашем примере, это будет список ['1', '2', '3'].
4. Мы используем метод ''.join(), чтобы объединить элементы списка в одну строку. В нашем примере, это будет строка '123'.
5. Наконец, мы выводим результат, используя функцию print(). В нашем примере, это будет вывод "123".

Это решение решает поставленную задачу и приводит к ожидаемому результату. Намеренно было выбрано простое решение, чтобы его легко понимали школьники.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика