Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матрицы

Kalimovnadir Kalimovnadir    1   16.09.2019 18:30    5

Ответы
urmanovae1983 urmanovae1983  07.10.2020 20:17
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(m,n,-99,99); a.Println(4); Writeln;
  Writeln('Max=',a.ElementsByRow.Max)
end.

Пример
Количество строк и столбцов в матрице: 5 8
*** Исходная матрица ***
  37  27  -8 -40 -85 -36  62  90
 -60 -14 -18   0 -50  77 -19 -36
  14 -98 -80  81  -8  83  84  26
 -65  74  12 -77 -84  -4 -51 -93
  94  34  45  23 -53 -55  55 -45

Max=94
ПОКАЗАТЬ ОТВЕТЫ
cristinapavlova cristinapavlova  07.10.2020 20:17
Создается матрица 10х10, заполняется случайными числами от 0 до 100, выводит исходную матрицу и Max элемент.
Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матр
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика