Напишите программу, которая заполняет массив из n=10 случайными числами в диапазоне {100; 300} и выводит его на экран. после этого на экран выводятся средние цифры(число десятков) всех чисел, записанных в массив. пример: массив: 142 324 135 257 число десятков: 4 2 3 5

alexmmv2013 alexmmv2013    1   23.09.2019 03:40    31

Ответы
HwaSa77816 HwaSa77816  10.09.2020 14:47
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
write('массив: ');
var a:=ArrRandom(10,100,300).Println;
write('число десятков: ');
a.ForEach(x->write(x.ToString[2],' '));
end.
ПОКАЗАТЬ ОТВЕТЫ
УЕД УЕД  10.09.2020 14:47
Const n=10;
var a: array [1..n] of integer;
i: integer;
begin
for i:=1 to n do
a[i]:=random(100,300);
writeln (a);
for i:=1 to n do
write (a[i] div 10 mod 10,'  ')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика