tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для вычисления
Составить программу для вычисления функции. y={x^2,если х< 2 √х,если х ≥ 2 0,если х=2
katysha087
2 18.09.2019 02:20
4
Ответы
younactja228
07.10.2020 23:05
Задание не совсем верно построено. Скорее всего вторая проверка должна быть строго больше двух, однако вот решение:
program ff;
var
y,x:real;
begin
writeln('Введите x');
readln(x);
if x<2 then y:=sqr(x);
if x>=2 then y:=sqrt(x);
if x=2 then y:=0;
writeln('y=',y);
readln();
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
makskatya20
12.12.2020 13:23
Зачастую требуется определить количество элементов, удовлетворяющих некоторому условию. В этом случае вводится переменная, значение которой увеличивается на единицу каждый раз, когда...
wjwjwjeuei
12.12.2020 13:24
Решать с применением цикла с предусловием: Написать программу паскаль табулирования функции на заданном промежутке с шагом 0.2...
СлишкомУмная1
12.12.2020 13:25
2. Система команд исполнителя, «живущего» в прямоугольном лабиринте на клетчатой плоскости: вверх, вниз, влево, вправо. При выполнении этих команд исполнитель перемещается на одну...
Sonia369
12.12.2020 13:28
15 в 10 степени умножить на 13 в 10 степени плюс 11 в 10 степени ...
родтчса
09.07.2019 18:10
Расположим по алфавиту десять слов, обозначающих цифры в десятичной системе счисления. возьмём четыре последние из них и из соответствующих цифр составим максимально возможное трехзначное...
konoval1i
09.07.2019 18:10
Укажите наименьшее четырёхзначное шестнадцатеричное число, двоичная запись которого содержит ровно 6 нулей. в ответе запишите только само шестнадцатеричное число, основание системы...
abeldinova85
09.07.2019 18:00
Вкаком из вариантов объем информации больше 30 килобайт? а. 30000 байт б.245000 бит в.2^14 байт г.0,030297 мегабайт...
эмили40
04.05.2020 08:30
1) Беттің өлшемдерін орнату амалы?2) Бетке жақтаулар мен жиектер қалай орнатылады?3) Алдын ала көру командасы қалай орындалады?4) Құжатты баспаға басу командасы қалай орындалады?5)...
Nasvay228
08.07.2019 03:10
Информационный вес символа 6 бит .определите объём сообщения состоящего из 30 символов....
віка189
08.07.2019 03:10
Нарисуй в тетради те предметы которые могут быть опасными.зеленым что можно брать самому,без родителей.желтым что можно брать на глазах у взрослых.а красным только то что могут брать...
Популярные вопросы
Определите спряжения глаголов слушать думать падать решать возвращаться спрашивать...
2
Процедура форматирования текста предусматривает:...
2
Оксид трехвалентного элемента содержит 31,58% кислорода.вычислить эквивалент и...
3
Какая масса раствора с масовой долей азотной кислоты 63% потребуется для реакции...
2
Складіть речення з домомогою слив розплющіти тобі...
2
10-15 слов с непроизносимыми согласными в корне по алфавиту?...
1
Уравнение решите ! 6870+(n- 49980)= 7436...
2
Зачем ствол винтовки покрывают деревянной накладкой? 1)винтовку с деревянной накладкой...
1
Вычислите среднее арифметическое двузначных элементов, у которых цифры в числе...
1
Три примера определения горизонта по другим признакам кроме компаса)(типо где мох...
1
program ff;
var
y,x:real;
begin
writeln('Введите x');
readln(x);
if x<2 then y:=sqr(x);
if x>=2 then y:=sqrt(x);
if x=2 then y:=0;
writeln('y=',y);
readln();
end.