Напишите программу , которая выводит номера билетов, чтобы они не повторялись

mrPool10 mrPool10    2   20.05.2019 19:10    3

Ответы
Orxan1414 Orxan1414  14.06.2020 06:49

Я так понимаю намера билетов надо вывести в случайном порядке?

Пусть надо вывести в случайном порядке номера 100 билетов

program RND;

var a:array[1..100]of integer;

i.j,f:integer;

begin

randomize;

i:=1;

white i<101 do begin

f:=0;

A[i]:=int(random(100));

for j:=1 to i do if A[j]=A[i] then f:=1;

if f=0 then i:=i+1;

end;

for i:=1 to 100 do writeln(A[i]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика