Напишите программу, которая выводит на экран все цифры числа, начиная с первой.входные данныевходная строка содержит натуральное число n .выходные данныепрограмма должна вывести все цифры введённого числа в одной строке, начиная с первой. цифры отделяются пробелами.примерывходные данные123выходные
данные 1 2 3только через паскаль абс циклы for, while

asikg27 asikg27    1   08.10.2019 09:04    31

Ответы
Luba0111 Luba0111  10.10.2020 03:54

var N,t,k,N1:integer;

BEGIN

readln(N);

N1:=N;

k:=0;

while (N1 mod 10=0) do begin

k:=k+1;

N1:=N1 div 10;

end;

t:=0;

while N>0 do begin

t:=t*10 + (N mod 10);

N:=N div 10;

end;

while t>0 do begin

write(t mod 10,' ');

t:=t div 10;

end;

for N:=1 to k do

write('0 ');

end.

ПОКАЗАТЬ ОТВЕТЫ
dzhele19 dzhele19  10.10.2020 03:54

program Digits;

procedure foo(a: integer);

begin

 if a = 0 then exit

 else

   foo(a div 10);

 Print(a mod 10)

end;

var

 a: integer;

begin

 a := 12345;

 foo(a)

end.


Напишите программу, которая выводит на экран все цифры числа, начиная с первой.входные данныевходная
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика